MacNOMODO

Où on cause du Mac - A consommer sans modération

 
PortailPortailAccueilRechercherRechercherFAQS'enregistrerMembresConnexion

Partagez | 
 

 Numbers: à propos des doublons

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
flg
Blanc bec
Blanc bec


Nombre de messages : 3
Date d'inscription : 22/05/2010

MessageSujet: Numbers: à propos des doublons   5/22/2010, 08:46

Bonjour,
J'ai lu avec intérêt la série de message sur l'utilisation avancée de Numbers 09, mais il me reste un problème pour l'instant insoluble.
Voici mon exemple:
Un tableau simple avec une colonne contenant une liste dont les éléments peuvent se répéter (TABLEAU1):

Code:

    A
1  John
2  Paul
3  Paul
4  Ringo
5  Georges
6  John
7  Georges
8  Georges
9  Ringo
10 Paul
11 Paul
12 …

A partir de TABLEAU1, je souhaiterai générer "dynamiquement" le tableau 2 qui contient les éléments uniques de la liste, ainsi que le nombre d'occurrence (TABLEAU2):

Code:

  A                  B
1 Paul              4
2 John              2
3 Georges            3
4 Ringo              2
Ca devrait être simple, mais je ne parvient pas à régler ce problème.
Merci par avance pour vos idées.

flg
Revenir en haut Aller en bas
flg
Blanc bec
Blanc bec


Nombre de messages : 3
Date d'inscription : 22/05/2010

MessageSujet: Re: Numbers: à propos des doublons   5/22/2010, 09:16

Pour la seconde colonne de TABLEAU 2, le problème est facilement réglé par
B1=NB.SI(TABLEAU1::A1:A11;A1)
B2=NB.SI(TABLEAU1::A1:A11;A2)


Mais je ne parviens pas à générer automatiquement la colonne A du tableau2 à partir de la colonne A du tableau1

Merci
Revenir en haut Aller en bas
Pomme-I
Enkysté
Enkysté


Nombre de messages : 1993
Date d'inscription : 13/12/2006

MessageSujet: Re: Numbers: à propos des doublons   5/22/2010, 10:10

Je n'ai pas Numbers, donc je te réponds en Excel :
il faudrait quelque chose du genre
1e ligne=SI(NB.SI($A$1:A1;A1)=1;A1;"")
2e ligne=SI(NB.SI($A$1:A2;A2)=1;A2;"")
….
en ajoutant tes liaisons à TABLEAU1 ($A$1 est une référence absolue)
Le principe : tu n'affiches le contenu de la cellule que si c'est sa 1e apparition.
Du coup tu peux n'afficher le nombre d'occurrences que si la cellule correspondante n'est pas vide.
Je ne sais pas comment tu peux supprimer les lignes vides.
Revenir en haut Aller en bas
flg
Blanc bec
Blanc bec


Nombre de messages : 3
Date d'inscription : 22/05/2010

MessageSujet: Re: Numbers: à propos des doublons   5/22/2010, 10:47

Pomme-I a écrit:
Je n'ai pas Numbers, donc je te réponds en Excel :
il faudrait quelque chose du genre
1e ligne=SI(NB.SI($A$1:A1;A1)=1;A1;"")
2e ligne=SI(NB.SI($A$1:A2;A2)=1;A2;"")
….
en ajoutant tes liaisons à TABLEAU1 ($A$1 est une référence absolue)
Le principe : tu n'affiches le contenu de la cellule que si c'est sa 1e apparition.
Du coup tu peux n'afficher le nombre d'occurrences que si la cellule correspondante n'est pas vide.
Je ne sais pas comment tu peux supprimer les lignes vides.

Ca fonctionne bien, nonobstant les lignes vides. Je parviens à rassembler les lignes vides au début du tableau en n'affichant le contenu que si c'est sa dernière apparition, et ces lignes sont ainsi plus faciles à masquer. En attendant de trouver la solution définitive, merci beaucoup pour ton aide.
Revenir en haut Aller en bas
TG
Légende vivante
Légende vivante


Nombre de messages : 5456
Age : 53
Planète : Paradis n°2
Matos : MacBook Pro Unibody 2.54 late 2008 Mountain Lion • MacPlus • PIXMA iP4300 • Scanner Epson Photo 330
Date d'inscription : 12/11/2006

MessageSujet: Re: Numbers: à propos des doublons   5/22/2010, 17:40

Salut flg.
Ton besoin correspond tout simplement à un tableau croisé dynamique à une dimension (pour lequel, croisé est un abus de langage).
Tu pourras donc t'appuyer avec profit sur les formules ou sur l'AppleScript proposés.

Voilà le résultat du script (qui ne fait que t'assister dans le création des formules en fait) :

_______________
[MacJams] [RouteBuddy] [Winckler] [Panoramio] [ePhotos]
Revenir en haut Aller en bas
http://www.panoramio.com/user/616684
Contenu sponsorisé




MessageSujet: Re: Numbers: à propos des doublons   Aujourd'hui à 06:47

Revenir en haut Aller en bas
 
Numbers: à propos des doublons
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
MacNOMODO :: A i d e  &  d é p a n n a g e :: Aspects logiciels-
Sauter vers: