MacNOMODO

Où on cause du Mac - A consommer sans modération

 
PortailPortailAccueilRechercherRechercherFAQS'enregistrerMembresConnexion

Partagez | 
 

 problème sur local host my php admin !

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
globereveuse
Blanc bec
Blanc bec


Nombre de messages : 7
Date d'inscription : 30/09/2015

MessageSujet: problème sur local host my php admin !   9/30/2015, 20:51

Bonjour à tous !

J'ai besoin de votre aide !
J'ai fait une copie de mon blog en local et maintenant il faut que je le remette en ligne. Je suis des tutos en ligne mais voici mon probleme.

Lorsque j'essaye d'aller sur l'adresse localhost phpmyadmin (je suis sous mac OS et j'utilise MAMP) : voici le message d'erreur qui s'affiche : Permissions sur le fichier de configuration incorrectes, il ne doit pas être en écriture pour tout le monde !

J'ai parcouru les forums et ne trouve pas la solution !
Je ne sais plus quoi faire

Pouvez-vous m'aider s'il vous plait?

Merci
Revenir en haut Aller en bas
hr
Légende vivante
Légende vivante


Nombre de messages : 6281
Age : 62
Planète : Creuse
Matos : iMac alu en OS 10.10 - G4 en OS 10.5 - MacBook Pro (90% en Ubuntu, 10% en OS X 10.6) - PC en Ubuntu 16.04
Date d'inscription : 19/11/2006

MessageSujet: Re: problème sur local host my php admin !   10/1/2015, 06:05

Je ne suis pas sûr de bien comprendre ton contexte. Tu as ce problème lorsque tu essayes d’utiliser phpmyadmin sur ta machine locale, c’est bien ça ?

Le message semble dire que les droits sont autorisés en écriture pour tout le monde mais si ton serveur et tout ce qui tourne autour, php mysql et phpmyadmin, est installé par mamp, les droits devraient être corrects si tu n’as touché à rien manuellement et en particulier des copies ou modifications directement.

Tu n’as pas précisé si tu avais simplement ce message ou si ça bloquait l’accès.
Le blog, en dehors de phpmyadmin, fonctionne-t-il sur ta machine locale ?
Comment as-tu rapatrié ton site sur ta machine ?


Regarde déjà les droits du fichier de configuration de phpmyadmin pour commencer et compare-les à ceux des autres fichiers de phpmyadmin.

Par ailleurs précise aussi la version de ton OS.

_______________
On ne fait jamais d’erreur sans se tromper !
L’affaire est dans le sac de Prévert et Prévert
Revenir en haut Aller en bas
globereveuse
Blanc bec
Blanc bec


Nombre de messages : 7
Date d'inscription : 30/09/2015

MessageSujet: Re: problème sur local host my php admin !   10/1/2015, 12:58

mac OS X Yosemite version 10.10.5

J'ai fait une copie en locale de mon blog et je n'ai modifie que le wpconfig. maintenant que je veux remettre la version locale en ligne cela me marque ce message d'erreur lorsque je veux aller sur local host myphpadmin pour pouvoir effectuer les modifs nécessaire a la mise en ligne. j'ai bien remodifie wpconfig comme il était au début.

si je vais sur mon blog voici le message d'erreur qui s'affiche : Parse error: syntax error, unexpected 'perso’' (T_STRING) in /home/globerev/www/wp-config.php on line 31

Je suis bêtement les tutoriels que je trouve pour modifier mon blog et je ne touche a rien d'autre donc c'est pour ça que je ne sais pas quoi faire.

Quand tu dis de regarder les fichiers de configuration de phpmyadmin c'est quoi?
Merci de votre aide !
Revenir en haut Aller en bas
hr
Légende vivante
Légende vivante


Nombre de messages : 6281
Age : 62
Planète : Creuse
Matos : iMac alu en OS 10.10 - G4 en OS 10.5 - MacBook Pro (90% en Ubuntu, 10% en OS X 10.6) - PC en Ubuntu 16.04
Date d'inscription : 19/11/2006

MessageSujet: Re: problème sur local host my php admin !   10/1/2015, 16:59

Parse error est une erreur de syntaxe php. Tu as visiblement fait une erreur dans le fichier wp-config.php et il devrait être facile de la trouver puisque le message indique qu’elle se trouve à la ligne 31. Ça peut être une parenthèse, un point virgule qui manque.

Il précise qu’il trouve une chaîne qui ne devrait pas se trouver là, peut-être as-tu oublié un ' ou un " pour encadrer une chaîne de caractères dans la ligne.

Le perso’ je ne sais pas ce que c’est mais c’est typiquement un caractère en UTF-8 (ou éventuellement trois caractères dans un encodage mono-octet quelconque mais pas en ascii pur) qui n’a pas été encodé correctement dans le message d’erreur, ça c’est clair, et tu devrais trouver tout ça en ligne 31. C’est peut-être ce mot qui devrait être entre '' ou "". Compare au fichier original si tu l’as encore.

_______________
On ne fait jamais d’erreur sans se tromper !
L’affaire est dans le sac de Prévert et Prévert
Revenir en haut Aller en bas
globereveuse
Blanc bec
Blanc bec


Nombre de messages : 7
Date d'inscription : 30/09/2015

MessageSujet: Re: problème sur local host my php admin !   10/1/2015, 21:50

je n'ai plus le fichier originale malheureusement.
j'ai regarde la ligne 31 et il s'agit du DB Host que voici : define('DB_HOST', ‘mysql55-117.perso’);
J'ai reecrit a la main le code et j'ai meme fait un copier coller mais l'erreur persiste !
J'ai demande a OVH qu'il me reconfirme le DB Host et c'est bien celui que j'ai indique
Revenir en haut Aller en bas
hr
Légende vivante
Légende vivante


Nombre de messages : 6281
Age : 62
Planète : Creuse
Matos : iMac alu en OS 10.10 - G4 en OS 10.5 - MacBook Pro (90% en Ubuntu, 10% en OS X 10.6) - PC en Ubuntu 16.04
Date d'inscription : 19/11/2006

MessageSujet: Re: problème sur local host my php admin !   10/1/2015, 22:26

hahaha ! une erreur bien cachée ! Avec quoi as-tu tapé ton code ? Dans un traitement de texte qui corrige la typographie ? Ou as-tu l’habitude d’y faire attention et as-tu tapé machinalement ce qui serait correct dans un texte mais qui est mortel dans du code ?

Regarde la fin de ta ligne, tu as des vrais guillemets anglais autour de mysql55-117.perso alors évidemment l’interpréteur y perd son latin.
Il faut écrire avec les faux guillemets anglais ' ' et non ‘ ’. C’est à dire ceux qui sont sous le 4 du clavier mais tels qu’ils sortent sur un éditeur de texte pur.

Comme pour un vrai texte il faut les guillemets courbes ouvrant et fermant, les traitements de texte corrigent automatiquement. Ce qui en l’occurrence produit une erreur parce qu’on est dans du code…

Pour du code, il faut impérativement utiliser un éditeur de texte fait pour ça et surtout pas un traitement de texte genre Pages, Word, LibreOffice etc.
Tu en as un bon et gratuit ici :
TextWrangler 5.0

ou celui-là, gratuit lui aussi :
Editra 0.7.20

_______________
On ne fait jamais d’erreur sans se tromper !
L’affaire est dans le sac de Prévert et Prévert
Revenir en haut Aller en bas
globereveuse
Blanc bec
Blanc bec


Nombre de messages : 7
Date d'inscription : 30/09/2015

MessageSujet: Re: problème sur local host my php admin !   10/1/2015, 22:36

je vais essayer merci beaucoup !!!
Revenir en haut Aller en bas
TG
Légende vivante
Légende vivante


Nombre de messages : 5456
Age : 53
Planète : Paradis n°2
Matos : MacBook Pro Unibody 2.54 late 2008 Mountain Lion • MacPlus • PIXMA iP4300 • Scanner Epson Photo 330
Date d'inscription : 12/11/2006

MessageSujet: Re: problème sur local host my php admin !   10/2/2015, 21:54

hr a écrit:
hahaha ! une erreur bien cachée ! Avec quoi as-tu tapé ton code ?

Effectivement, il faut un éditeur qui n'ait pas trop la quote Complice

_______________
[MacJams] [RouteBuddy] [Winckler] [Panoramio] [ePhotos]
Revenir en haut Aller en bas
http://www.panoramio.com/user/616684
globereveuse
Blanc bec
Blanc bec


Nombre de messages : 7
Date d'inscription : 30/09/2015

MessageSujet: Re: problème sur local host my php admin !   10/3/2015, 14:34

Merci ! c'etait bien une erreur de guillemet !

Maintenant que le problème est réglé il y en a encore deux autres !!

- Je ne peux toujours pas me connecter à localhost myphpadmin car cela me marque que j'ai pas les droit d écriture.
a cause de cela je ne peux pas remettre mon blog en ligne !!!

- De plus, j'ai fait un essai pour me connecter a mon blog et cela me dit erreur de connexion a la base de donnée. j'ai contacte OVH et ils me disent qu'il n'y a aucun problème !!

Encore une fois merci de votre retour !
Revenir en haut Aller en bas
hr
Légende vivante
Légende vivante


Nombre de messages : 6281
Age : 62
Planète : Creuse
Matos : iMac alu en OS 10.10 - G4 en OS 10.5 - MacBook Pro (90% en Ubuntu, 10% en OS X 10.6) - PC en Ubuntu 16.04
Date d'inscription : 19/11/2006

MessageSujet: Re: problème sur local host my php admin !   10/3/2015, 15:10

globereveuse a écrit:
Je ne peux toujours pas me connecter à localhost myphpadmin car cela me marque que j'ai pas les droit d écriture.
a cause de cela je ne peux pas remettre mon blog en ligne !!!
Es-tu toujours sur ta machine locale quand tu as cette erreur ou as-tu le problème sur le blog en ligne ?

globereveuse a écrit:
De plus, j'ai fait un essai pour me connecter a mon blog et cela me dit erreur de connexion a la base de donnée. j'ai contacte OVH et ils me disent qu'il n'y a aucun problème !!
Es-tu sûr que ton nom d’utilisateur et ton mot de passe sont bien ceux de la base sur OVH ? De mémoire (ça remonte à un certain temps), ce ne sont pas les mêmes que ceux de l’accès ftp, chez OVH. Il faut prendre les codes qui t’ont été fourni lors de l’ouverture de la base chez eux. Si c’est déjà bien le cas, je vais avoir du mal à t’aider comme ça à distance. On essayera mais ça risque de ne pas être facile.

Dans ton code php, il faut que ce soient ces nom d’utilisateur et mot de passe qui soient indiqués.
Avais-tu déjà réussi à te connecter à mysql avant ta manœuvre de transfert aller-retour ?

_______________
On ne fait jamais d’erreur sans se tromper !
L’affaire est dans le sac de Prévert et Prévert
Revenir en haut Aller en bas
globereveuse
Blanc bec
Blanc bec


Nombre de messages : 7
Date d'inscription : 30/09/2015

MessageSujet: Re: problème sur local host my php admin !   10/3/2015, 15:21

Je suis sur le local lorsque le message s'affiche.


Ce qui est bizarre c'est que je peux me connecter a phpmyadmin mes identifiants et mot de passe fonctionne mais si je vais sur localhost cela me met cette erreur. Hors, c'est sur le site localhost que je dois faire mes modifications pour remettre mon blog en ligne.
Revenir en haut Aller en bas
hr
Légende vivante
Légende vivante


Nombre de messages : 6281
Age : 62
Planète : Creuse
Matos : iMac alu en OS 10.10 - G4 en OS 10.5 - MacBook Pro (90% en Ubuntu, 10% en OS X 10.6) - PC en Ubuntu 16.04
Date d'inscription : 19/11/2006

MessageSujet: Re: problème sur local host my php admin !   10/3/2015, 15:42

Si phpmyadmin se connecte, c’est que l’identifiant et le mot de passe sont bons. Ton code doit donc pouvoir se connecter de la même manière.

Tu dois avoir quelque part une ligne de php qui doit ressembler grosso-modo à quelque chose du genre :

$connexion = mysql_connect("localhost", "root", "mot_de_passe");

avec $connexion qui est la variable contenant la référence de la connexion et mot_de_passe le même mot de passe que celui de root utilisé par phpmyadmin pour se connecter à la base.

Peux-tu vérifier que ce sont bien les deux mêmes identifiant (root en principe) et mot de passe dans le code et dans la configuration de phpmyadmin ?

_______________
On ne fait jamais d’erreur sans se tromper !
L’affaire est dans le sac de Prévert et Prévert
Revenir en haut Aller en bas
globereveuse
Blanc bec
Blanc bec


Nombre de messages : 7
Date d'inscription : 30/09/2015

MessageSujet: Re: problème sur local host my php admin !   10/3/2015, 16:18

Ou je peux trouver cette ligne de php? Dans quel fichier?

Si tu veux je peux te donner mes identifiants pour que tu es accèsau tuto en ligne que j ai suivi pour le faire. Vu que je suis novice en iinformatique je suis le tuto sans trop me poser de questions. Comme ca je te dit ou ca bloque? Ca sera sans doute plus simple
Revenir en haut Aller en bas
hr
Légende vivante
Légende vivante


Nombre de messages : 6281
Age : 62
Planète : Creuse
Matos : iMac alu en OS 10.10 - G4 en OS 10.5 - MacBook Pro (90% en Ubuntu, 10% en OS X 10.6) - PC en Ubuntu 16.04
Date d'inscription : 19/11/2006

MessageSujet: Re: problème sur local host my php admin !   10/3/2015, 19:26

On peut y repenser si on n’arrive à rien mais en attendant explique-moi exactement ce que tu as fait.

Pour ce qui est de trouver la ligne, je ne peux pas savoir où puisque je ne connais pas le code de ton site. Je pensais que tu avais modifié un script quelque part dans les fichiers et que ça se situait dans ce code. On laisse tomber ça puisque ce n’est visiblement pas le cas.

Je répète ma question à laquelle tu n’as pas répondu :
1) Avais-tu déjà réussi à te connecter à mysql avant ta manœuvre de transfert aller-retour ? Je précise sur ton site chez OVH.

2) As-tu pu faire fonctionner ton blog en local avant même de te connecter ? Autrement dit, as-tu pu voir la page d’accueil et ce qui est public ?

Ce qu’il y a surtout, c’est que je ne comprends pas exactement ce que tu entends quand tu dis que tu essayes de te connecter en localhost. Puisqu’il ne s’agit pas de la connexion sur localhost par ton code php, qu’est-ce ? Donc troisième question :
3) Puisque phpmyadmin arrive à se connecter, c’est une autre manœuvre de connexion qui échoue, laquelle ?

Il a bien fallu que tu trouves quelque part le code d’accès et le mot de passe de ta base mysql. C’est ceux que tu utilises pour que tu te connectes à phpmysql. Ceux-là sont bons puisque tu arrives à te connecter. Ils t’ont certainement été fournis par OVH. D’où :

4) Est-ce que ce sont ces codes d’accès que tu utilises pour cette fameuse connexion sur localhost ?

Je ne sais pas ce que tu as fait quand tu parles d’avoir recopié ton blog sur ta machine. As-tu exporté la base depuis le site chez OVH avec le phpmyadmin de là-bas et l’as-tu importée dans une installation mysql locale vide créée par MAMP avec ton phpmyadmin local ?

5) Comment as-tu rapatrié ton site sur ta machine ?
Tu m’as répondu que tu as fait une copie de ton blog mais ça ne me dit pas grand chose. As-tu recopié tous les fichiers php et reconstitué l’ensemble sur ta machine ?

_______________
On ne fait jamais d’erreur sans se tromper !
L’affaire est dans le sac de Prévert et Prévert
Revenir en haut Aller en bas
Contenu sponsorisé




MessageSujet: Re: problème sur local host my php admin !   Aujourd'hui à 23:52

Revenir en haut Aller en bas
 
problème sur local host my php admin !
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
MacNOMODO :: A i d e  &  d é p a n n a g e :: Aspects logiciels-
Sauter vers: