MacNOMODO

Où on cause du Mac - A consommer sans modération

 
PortailPortailAccueilRechercherRechercherFAQS'enregistrerMembresConnexion

Partagez | 
 

 LibreOffice : Java pas la tête !

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Doubleyou
Légende vivante
Légende vivante


Nombre de messages : 5782
Age : 47
Planète : de dingues
Matos : un truc avec une pomme dessus et d'autres machins coûteux
Date d'inscription : 19/11/2006

MessageSujet: LibreOffice : Java pas la tête !   10/22/2016, 16:06

Dans la série "Les macusers on s'en fout" voici le dernier épisode produit par la Document Fondation et son réalisateur LibreOffice.

J'ai déjà signalé par ici les demandes intempestive d'installation de Java que m'occasionnaient jadis Writer version LO. Un phénomène d'autant plus incompréhensible qu'il ne se produisait pas avec l'excellente suite Apache OpenOffice.

Depuis quelques temps, le monde des forums d'entraide Mac est sollicité par des demandes concernant l'installation de Java en rapport direct avec LibreOffice, la consigne qui consistait à installer le vieux Java SE 6 n'étant plus d'actualité.

L'installation du dernier Java 8 JRE telle que réclamée par LibreOffice 5.x.x. ne semble pas suffire sur OS X. Loin de là.

http://nabble.documentfoundation.org/Environnement-Java-td4176649.html

Maintenant, il est conseillé d'installer le Java 8 JDK !

Oui. Vous lisez bien, ce n'est pas une coquille. Pour utiliser LibreOffice avec Java il faut se coltiner l'environnement développeur Java.

Jambon

La discussion mise en lien ci-dessus vous apprendra que ce sont les changements apportés à LibreOffice qui ont entrainé cette situation, dans le plus total mépris des utilisateurs de macOS. Il y est aussi évoqué l'inconvénient majeur concernant la sécurité que constitue cette installation : contrairement au JRE, le JDK ne dispose pas de mise à jour automatique. Ce n'est pas un point de détail lorsqu'on pense à la sensibilité de Java aux attaques les plus dangereuses.


Il me souvient que lors de la sécession des brailleurs de la Document Fondation (2010), il était promis un affranchissement progressif de Java. Six ans après, on se retrouve sur OS X à installer l'environnement développeur Java.

Bravo.

J'attends avec impatience le retour de X11.

[Il y a d'ailleurs dans la discussion un pingouin qui propose d'en passer par Homebrew… Les pingouins sont comme les cons d'Audiard, ils osent tout.]


La solution : Apache OpenOffice 4.1.3

_______________
Art. 10. Nul ne doit être inquiété pour ses opinions, même religieuses, pourvu que leur manifestation ne trouble pas l'ordre public établi par la Loi.
Art. 11. La libre communication des pensées et des opinions est un des droits les plus précieux de l'Homme : tout Citoyen peut donc parler, écrire, imprimer librement, sauf à répondre de l'abus de cette liberté dans les cas déterminés par la Loi.
Art. 12. La garantie des droits de l'Homme et du Citoyen nécessite une force publique : cette force est donc instituée pour l'avantage de tous, et non pour l'utilité particulière de ceux auxquels elle est confiée.
Revenir en haut Aller en bas
http://www.crawford-texas.org/
TG
Légende vivante
Légende vivante


Nombre de messages : 5457
Age : 53
Planète : Paradis n°2
Matos : MacBook Pro Unibody 2.54 late 2008 Mountain Lion • MacPlus • PIXMA iP4300 • Scanner Epson Photo 330
Date d'inscription : 12/11/2006

MessageSujet: Re: LibreOffice : Java pas la tête !   10/22/2016, 21:19

Y a besoin de Java pour LO que sur OSX ?

_______________
[MacJams] [RouteBuddy] [Winckler] [Panoramio] [ePhotos]
Revenir en haut Aller en bas
http://www.panoramio.com/user/616684
Doubleyou
Légende vivante
Légende vivante


Nombre de messages : 5782
Age : 47
Planète : de dingues
Matos : un truc avec une pomme dessus et d'autres machins coûteux
Date d'inscription : 19/11/2006

MessageSujet: Re: LibreOffice : Java pas la tête !   10/22/2016, 23:04

Non, sur les autres plateformes également.

Mais il n'y a que sur OS X que nous sommes contraints d'installer le JDK, suite à des changements apportés dans LibreOffice 5.1.

5.0.x ça fonctionne avec le JRE, 5.1.x ça ne fonctionne plus. => installez le JDK (plus lourd, moins sécurisé)

Le plus sidérant sont les réponses apportées par les gens de LO, en gros :
– c'est un bug Apple, voire c'est un problème Oracle ;
– il n'y a rien à corriger parce que c'est à Apple de s'adapter à LO et pas l'inverse ;
– ce n'est pas parce que ça fonctionnait avant que ça doit fonctionner après ;
– si ça te dérange répare-le toi-même.

Source : http://nabble.documentfoundation.org/Java-still-broke-on-LibreOffice-5-1-1-td4178215.html


Ce qui transparait dans cette affaire c'est une fois de plus le mépris affiché envers la plateforme OS X.

Personnellement, cela ne m'étonne pas. J'avais dit à l'époque du fork de la Document Fondation que le Mac serait la cinquième roue du carrosse de ces gens car ce sont les mêmes personnes qui pendant des années nous ont laissé végéter sur X11.

Ils nous ont déjà abandonné pendant plus de six mois avec un export PDF déficient tout en continuant à publier de nouvelles versions de leur suite, correctrices de tout sauf ce qui concernait OS X. Aujourd'hui, ils ne se fatiguent même plus à rendre leur suite compatible Mac.

_______________
Art. 10. Nul ne doit être inquiété pour ses opinions, même religieuses, pourvu que leur manifestation ne trouble pas l'ordre public établi par la Loi.
Art. 11. La libre communication des pensées et des opinions est un des droits les plus précieux de l'Homme : tout Citoyen peut donc parler, écrire, imprimer librement, sauf à répondre de l'abus de cette liberté dans les cas déterminés par la Loi.
Art. 12. La garantie des droits de l'Homme et du Citoyen nécessite une force publique : cette force est donc instituée pour l'avantage de tous, et non pour l'utilité particulière de ceux auxquels elle est confiée.
Revenir en haut Aller en bas
http://www.crawford-texas.org/
TG
Légende vivante
Légende vivante


Nombre de messages : 5457
Age : 53
Planète : Paradis n°2
Matos : MacBook Pro Unibody 2.54 late 2008 Mountain Lion • MacPlus • PIXMA iP4300 • Scanner Epson Photo 330
Date d'inscription : 12/11/2006

MessageSujet: Re: LibreOffice : Java pas la tête !   10/23/2016, 09:16

Du coup, il est sans doute pas mal de rester avec une version antérieure qui nous convient et de cesser de faire la course à la dernière release. Sauf bug pénalisant à l'usage.

http://downloadarchive.documentfoundation.org/libreoffice/old/

Perso, j'ai cessé cette course. J'utilise la 5.0.6.3 sur un vieux MBPU de 2008 animé par ML.
Il me lachera un jour et je mettrai tout à jour à ce moment là (pas le choix).

_______________
[MacJams] [RouteBuddy] [Winckler] [Panoramio] [ePhotos]
Revenir en haut Aller en bas
http://www.panoramio.com/user/616684
hr
Légende vivante
Légende vivante


Nombre de messages : 6281
Age : 62
Planète : Creuse
Matos : iMac alu en OS 10.10 - G4 en OS 10.5 - MacBook Pro (90% en Ubuntu, 10% en OS X 10.6) - PC en Ubuntu 16.04
Date d'inscription : 19/11/2006

MessageSujet: Re: LibreOffice : Java pas la tête !   10/23/2016, 10:05

Un splendide mauvais replâtrage en catastrophe, on dirait !

Tel que c’est, c’est évidemment une situation pourrie mais ça ne concerne que la partie Base de LO. Le reste n’a pas besoin d’un quelconque runtime java. Chez moi, en OS 10.10 je n’en ai pas et le tableur et le traitement de texte fonctionnent très bien.



Le module Base est un vieux résidu qui n’est maintenu que pour faire tourner les applis de Base existantes. J’ai essayé de ’en servir il y a longtemps et j’ai vite renoncé à utiliser ce clone du très effroyable Access.

_______________
On ne fait jamais d’erreur sans se tromper !
L’affaire est dans le sac de Prévert et Prévert
Revenir en haut Aller en bas
Contenu sponsorisé




MessageSujet: Re: LibreOffice : Java pas la tête !   Aujourd'hui à 14:33

Revenir en haut Aller en bas
 
LibreOffice : Java pas la tête !
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
MacNOMODO :: A i d e  &  d é p a n n a g e :: Aspects logiciels-
Sauter vers: