MacNOMODO

Où on cause du Mac - A consommer sans modération

 
PortailPortailAccueilRechercherRechercherFAQS'enregistrerMembresConnexion

Partagez | 
 

 (résolu!) Problème connexion

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Peacemaker
Enkysté
Enkysté


Nombre de messages : 1392
Age : 49
Planète : Mars
Matos : MacBookPro 15' (2011), iPad4, Wacom Pen&Touch
Date d'inscription : 28/11/2006

MessageSujet: (résolu!) Problème connexion   9/28/2007, 13:24

Salut à tous.
J'ai un petit problème de connexion internet très bizarre:
J'ai un routeur, sur lequel est connecté mon eMac, mon iBook et... le PC des voisins (ne le dites pas à mon FAI...). Tout ça est cablé en ethernet (pas de wifi donc) et relié au modem câble.
Depuis hier la connexion sur mon eMac est impossible. Sur les autres ordis, ça fonctionne sans problème.
En fait ce qui est curieux c'est que quand j'ouvre préfs réseau, tout est en vert et indique "vous êtes connecté à internet". Or quand je lance Mail, Safari, Firefox, iTunes ou toute autre appli qui se connectant à internet, rien, nada, niets, quedale, nib'. Safari affiche "vous n'êtes pas connecté à internet". Idem pour Mail et le reste.
J'ai réparé les autorisations, redémarré modem et routeur, j'ai même lancé un scan d'antivirus ! Tout ça en vain. Le "diagnostique réseau" ne donne rien non plus.
Mon firewall n'est pas activé. La connexion entre les ordis via le routeur fonctionne. Je peux accéder à l'eMac depuis l'iBook via ethernet. Il semble donc que ce soit un histoire de ports bloqués, non ? mais bon, j'y connais rien. Quelqu'un pourrait m'éclairé ? ou me guider dans un diagnostic ?
???

_______________
...
Jusqu' où les chauves se lavent-ils le visage ?
Revenir en haut Aller en bas
http://oriot.net
Peacemaker
Enkysté
Enkysté


Nombre de messages : 1392
Age : 49
Planète : Mars
Matos : MacBookPro 15' (2011), iPad4, Wacom Pen&Touch
Date d'inscription : 28/11/2006

MessageSujet: Re: (résolu!) Problème connexion   9/28/2007, 13:33

Ça y est ! Ça remarche !
escusé-moi pour l' dérangement...
J'ai comparé les champs renseignés dans les préfs réseau de l'iBook et de l'eMac et j'ai vu que "serveur DNS" n'était pas renseigné sur l'eMac (indiqué comme facultatif). J'ai donc mis la même chose que ce que je voyais sur l'iBook et... miracle la connexion est revenue...
Je ne me souviens absolument pas avoir mis le nez dans ces préferences et encore moins avoir modifié quoi que ce soit...
enfin... C'est pour moi un mystère.
Résolu !
Bienvenue

_______________
...
Jusqu' où les chauves se lavent-ils le visage ?


Dernière édition par le 9/28/2007, 14:54, édité 1 fois
Revenir en haut Aller en bas
http://oriot.net
hr
Légende vivante
Légende vivante


Nombre de messages : 6295
Age : 62
Planète : Creuse
Matos : iMac alu en OS 10.10 - G4 en OS 10.5 - MacBook Pro (90% en Ubuntu, 10% en OS X 10.6) - PC en Ubuntu 16.04
Date d'inscription : 19/11/2006

MessageSujet: Re: (résolu!) Problème connexion   9/28/2007, 14:00

Peacemaker a écrit:
Je ne me souviens absolument pas avoir le nez dans ces préferences et encore moins avoir modifié quoi que ce soit...
C’est une épidémie. Exactement le même symptôme chez moi. Réseau interne derrière le routeur parfait, pas de connexion vers l’extérieur sur une machine précise, les autres si. J’ai dû refaire la configuration en DHCP + adresse manuelle plutôt que config manuelle y compris l’adresse du routeur (qui fonctionnait pourtant depuis plus d’un an) et du coup ça remarche. Plus moyen de revenir à la config manuelle, ça refuse obstinément de remarcher vers l’extérieur !
Tout aussi mystérieux mais tout aussi résolu. Hein !?

_______________
On ne fait jamais d’erreur sans se tromper !
L’affaire est dans le sac de Prévert et Prévert
Revenir en haut Aller en bas
Peacemaker
Enkysté
Enkysté


Nombre de messages : 1392
Age : 49
Planète : Mars
Matos : MacBookPro 15' (2011), iPad4, Wacom Pen&Touch
Date d'inscription : 28/11/2006

MessageSujet: Re: (résolu!) Problème connexion   9/28/2007, 14:53

Bizarre en effet. Ça semble être grosso (no)modo le même problème.
Je ne me souviens pas si il y a eu une mise à jour particulière récemment, quelque chose qui aurait foutu le bronx...
Aurais-je fait une fausse manip' ? Quant à ma femme je suis sûr qu'elle n'ira jamais mettre son nez dans des réglages quelconques.
Mon chat peut-être ? A l'insu de son plein gré, alors.
Les voix du réseau sont impénétrables... (pour moi en tout cas.)

_______________
...
Jusqu' où les chauves se lavent-ils le visage ?
Revenir en haut Aller en bas
http://oriot.net
TG
Légende vivante
Légende vivante


Nombre de messages : 5470
Age : 53
Planète : Paradis n°2
Matos : MacBook Pro Unibody 2.54 late 2008 Mountain Lion • MacPlus • PIXMA iP4300 • Scanner Epson Photo 330
Date d'inscription : 12/11/2006

MessageSujet: Re: (résolu!) Problème connexion   9/28/2007, 19:19

Généralement, le routeur sait se comporter comme serveur DNS pour les machines (en réalité, il passe les plats ; c'est ce qu'on appelle un proxy DNS, c'est à dire DNS par procuration) internes qui, si elles n'ont pas de DNS défini, peuvent se renseigner auprès de la passerelle (le routeur donc, vous suivez ?). C'est pour ça que ça marche même si on oublie de faire le boulot comme il faut. Hélas, c'est comme tout, il arrive que le routeur (la passerelle donc, toujours là ?) manque à ses obligations.
Comment sait-on si un routeur sait assumer cette fonction ? Si en le paramétrant on peut/doit lui indiquer où se trouvent les serveurs DNS.
Bon, on n'a pas toujours la main sur son routeur. Les box sont des machins fermés mais toutes (toutes celles que je connais en tout cas) sont proxy DNS.

Il y a plus court comme explication (inspirée de la logique Shadok) : c'est parce que ça marche que ça peut tomber en panne.

_______________
[MacJams] [RouteBuddy] [Winckler] [Panoramio] [ePhotos]
Revenir en haut Aller en bas
http://www.panoramio.com/user/616684
Doubleyou
Légende vivante
Légende vivante


Nombre de messages : 5790
Age : 47
Planète : de dingues
Matos : un truc avec une pomme dessus et d'autres machins coûteux
Date d'inscription : 19/11/2006

MessageSujet: Re: (résolu!) Problème connexion   9/28/2007, 20:04

TG a écrit:
(...)

Il y a plus court comme explication (inspirée de la logique Shadok) : c'est parce que ça marche que ça peut tomber en panne.
Ben ouai mais ce passage-là, je l'ai compris... MDR

... enfin, je crois. Circonspect

W.

_______________
Art. 10. Nul ne doit être inquiété pour ses opinions, même religieuses, pourvu que leur manifestation ne trouble pas l'ordre public établi par la Loi.
Art. 11. La libre communication des pensées et des opinions est un des droits les plus précieux de l'Homme : tout Citoyen peut donc parler, écrire, imprimer librement, sauf à répondre de l'abus de cette liberté dans les cas déterminés par la Loi.
Art. 12. La garantie des droits de l'Homme et du Citoyen nécessite une force publique : cette force est donc instituée pour l'avantage de tous, et non pour l'utilité particulière de ceux auxquels elle est confiée.
Revenir en haut Aller en bas
http://www.crawford-texas.org/
hr
Légende vivante
Légende vivante


Nombre de messages : 6295
Age : 62
Planète : Creuse
Matos : iMac alu en OS 10.10 - G4 en OS 10.5 - MacBook Pro (90% en Ubuntu, 10% en OS X 10.6) - PC en Ubuntu 16.04
Date d'inscription : 19/11/2006

MessageSujet: Re: (résolu!) Problème connexion   9/28/2007, 20:11

TG a écrit:
Comment sait-on si un routeur sait assumer cette fonction ? Si en le paramétrant on peut/doit lui indiquer où se trouvent les serveurs DNS.
vivivivivivi, je te suis bien, mais zalors pourquoi qu’il y a 3 machines qui n’ont pas de problème sur le même routeur et une si, et tout ça en même temps ?
Parce qu’il vaut mieux tomber en panne même si on ne sait pas pourquoi que de fonctionner et de risquer une panne encore pire (professeur Shadoko in Pensées pompeuses).

_______________
On ne fait jamais d’erreur sans se tromper !
L’affaire est dans le sac de Prévert et Prévert
Revenir en haut Aller en bas
TG
Légende vivante
Légende vivante


Nombre de messages : 5470
Age : 53
Planète : Paradis n°2
Matos : MacBook Pro Unibody 2.54 late 2008 Mountain Lion • MacPlus • PIXMA iP4300 • Scanner Epson Photo 330
Date d'inscription : 12/11/2006

MessageSujet: Re: (résolu!) Problème connexion   9/28/2007, 20:53

hr a écrit:
vivivivivivi, je te suis bien, mais zalors pourquoi qu’il y a 3 machines qui n’ont pas de problème sur le même routeur et une si, et tout ça en même temps ?
Le PC des voisins je sais pas, mais l'iBook avait ses DNS renseignés. Pas l'eMac.

_______________
[MacJams] [RouteBuddy] [Winckler] [Panoramio] [ePhotos]
Revenir en haut Aller en bas
http://www.panoramio.com/user/616684
Gamma gt
Incrusté
Incrusté


Nombre de messages : 525
Age : 67
Planète : Hou là là
Matos : iMac 21,5 core 2 duo. 10.6.8
Date d'inscription : 20/11/2006

MessageSujet: Re: (résolu!) Problème connexion   9/28/2007, 21:05

TG a écrit:
hr a écrit:
vivivivivivi, je te suis bien, mais zalors pourquoi qu’il y a 3 machines qui n’ont pas de problème sur le même routeur et une si, et tout ça en même temps ?
Le PC des voisins je sais pas, mais l'iBook avait ses DNS renseignés. Pas l'eMac.


je constate une seule et unique chose :
pas besoin de verser sur bière sur le clavier gna gna gna gna gna gna
gamma
Revenir en haut Aller en bas
hr
Légende vivante
Légende vivante


Nombre de messages : 6295
Age : 62
Planète : Creuse
Matos : iMac alu en OS 10.10 - G4 en OS 10.5 - MacBook Pro (90% en Ubuntu, 10% en OS X 10.6) - PC en Ubuntu 16.04
Date d'inscription : 19/11/2006

MessageSujet: Re: (résolu!) Problème connexion   9/28/2007, 21:36

Gamma gt a écrit:
Le PC des voisins je sais pas, mais l'iBook avait ses DNS renseignés. Pas l'eMac.
Chez moi aucun n’a les dns renseignés. Il y a sans doute plusieurs raisons différentes de faire n’importe quoi pour un mac moyen…

_______________
On ne fait jamais d’erreur sans se tromper !
L’affaire est dans le sac de Prévert et Prévert
Revenir en haut Aller en bas
Peacemaker
Enkysté
Enkysté


Nombre de messages : 1392
Age : 49
Planète : Mars
Matos : MacBookPro 15' (2011), iPad4, Wacom Pen&Touch
Date d'inscription : 28/11/2006

MessageSujet: Re: (résolu!) Problème connexion   9/29/2007, 07:15

Je crois que j'ai compris comment marche le routeur. Mais pourquoi ça a marché pendant des mois sur les trois ordis et tout d'un coup plus sur un seul ?...
Bon j'admet que ça peut tomber en panne. Ce qui est déjà arrivé une couple de fois c'est que plus aucune des machines n'avait de connexion. Là je peux comprendre. Il m'a suffit de redemarrer le routeur et hop, réglé.

PS: je n'ai pas une box. C'est un routeur classique, installé il y a plusieurs mois par mon nerd de voisin (mais gentil) qui nous a proposé de partager notre connexion avec lui. C'est lui qui a fait tous les réglages (il a d'ailleurs été étonné de la facilité des réglages réseaux sur le Mac: basiquement il n'y avait quasiment rien à faire)
Il était pas là hier quand j'ai du régler ce problème.

_______________
...
Jusqu' où les chauves se lavent-ils le visage ?
Revenir en haut Aller en bas
http://oriot.net
Peacemaker
Enkysté
Enkysté


Nombre de messages : 1392
Age : 49
Planète : Mars
Matos : MacBookPro 15' (2011), iPad4, Wacom Pen&Touch
Date d'inscription : 28/11/2006

MessageSujet: Re: (résolu!) Problème connexion   9/29/2007, 07:18

Gamma gt a écrit:

je constate une seule et unique chose :
pas besoin de verser sur bière sur le clavier gna gna gna gna gna gna
gamma
Peut-être que mon chat a pisser sur le routeur ...
Non, c'est pas son genre...

_______________
...
Jusqu' où les chauves se lavent-ils le visage ?
Revenir en haut Aller en bas
http://oriot.net
Makomac
Enkysté
Enkysté


Nombre de messages : 1258
Age : 68
Planète : Terre
Matos : iMac 2,4 Ghz Intel -Leopard Snow - Macbook - 2,4 GHz - 2 Go - Leopard Snow
Date d'inscription : 19/11/2006

MessageSujet: Re: (résolu!) Problème connexion   9/29/2007, 07:19

Peacemaker a écrit:
Gamma gt a écrit:

je constate une seule et unique chose :
pas besoin de verser sur bière sur le clavier gna gna gna gna gna gna
gamma
Peut-être que mon chat a pisser sur le routeur ...
Non, c'est pas son genre...
Ton chat et la souris font-ils bon ménage? MDR

_______________
"Il faudrait convaincre les hommes du bonheur qu'ils ignorent, lors même qu'ils en jouissent" (Montesquieu).
Revenir en haut Aller en bas
TG
Légende vivante
Légende vivante


Nombre de messages : 5470
Age : 53
Planète : Paradis n°2
Matos : MacBook Pro Unibody 2.54 late 2008 Mountain Lion • MacPlus • PIXMA iP4300 • Scanner Epson Photo 330
Date d'inscription : 12/11/2006

MessageSujet: Re: (résolu!) Problème connexion   9/29/2007, 09:02

Peacemaker a écrit:
Je crois que j'ai compris comment marche le routeur. Mais pourquoi ça a marché pendant des mois sur les trois ordis et tout d'un coup plus sur un seul ?...
Tu veux dire que ça ne marchait plus sur un mais que ça marchait sur les autres (a)

ou

Tu veux dire que ça ne marchait plus sur aucun (b) ?

Parce que dans ta description d'origine, seul l'eMac était en rade alors que l'iBook et le PC continuaient à bénéficier de leur connexion.

[moquerie on]quand ça marche avant et que ça ne marche plus après, il n'y a pas de pourquoi : on appelle ça une panne et c'est tout[moquerie off]

Ceci dit, une panne peut être définitive, transitoire, aléatoire...

Revenons à notre affaire. Si nous sommes bien dans le cas (a) (laissons de côté le cas (b), c'est le caca :shame:), l'eMac n'était pas configuré comme les autres. Faute d'information, il s'appuyait sur le routeur pour obtenir les résolutions d'adresses alors que les autres s'adressaient directement aux serveurs DNS (comme quoi, on est toujours mieux servi par soi-même). Si le routeur a cessé, même momentanément, de faire son boulot (celui de proxy DNS, pas celui de routeur strict), seul les (la) machines qui dépendaient de lui ont été impactées.

Bon. Les réseaux, tant qu'on parle des seuls aspects de configuration des machines et des machins, ce n'est pas très compliqué. Néanmoins, étant donné le nombre des paramètres, dès qu'on a un peu de matériel (plusieurs micro, un modem, un routeur voire un point d'accès WiFi, un firewall, un serveur d'impression*, etc.), le nombre de combinaisons, donc le potentiel de panne, devient vite incroyablement élevé. Seule la rigueur de mise en œuvre et un peu de méthode permettent de réduire le temps à passer le jour où, inéluctablement, une panne se présentera.

Un réseau bien configuré se reconnaît à ce que tous les appareils utilisant un même service cessent d'y avoir accès en même temps pendant la même durée. Du coup il suffit de régler LE problème** pour que TOUT remarche.

Sinon, on risque pour une MEME cause d'obtenir PLUSIEURS effets différents et surtout, plus insidieux, plusieurs appareils qui vont continuer de fonctionner pour des raisons différentes. Un comble.

___________
* et encore, certains appareils réunissent parfois dans un seul boîtier plusieurs voire toutes ces fonctions. Il faut les configurer comme des appareils séparés et parfois même régler des soucis de communication entre les modules comme s'il s'agissait de matériels physiquement différents. Ce qui n'est pas fait pour faciliter la compréhension et la maîtrise par Mr Toutlemonde. Pour couronner le tout, les interfaces de "gestion" sont très souvent à chier, pleines de termes abscons (et hermétiques des fois mêmes aux utilisateurs chevronnés), munies d'une aide ridicule (extrait : "le bouton DHCP vous permet de configurer le serveur DHCP". Pas de doute, ça aide...) ou contre-productive (quand on comprend moins bien comment faire après l'avoir consultée).

** généralement, il est alors facile d'identifier la cause car un réseau bien configuré est en général bien maîtrisé et, c'est important, documenté. On s'est posé la question à l'installation de la façon de mettre les services à disposition. Du coup, quand un service cesse d'être disponible, on sait déjà en gros pourquoi et précisément où chercher.
Bon. Tout cela sera mature quand on ne se préoccupera plus de ça. C'est tout à fait possible. Ça viendra.

_______________
[MacJams] [RouteBuddy] [Winckler] [Panoramio] [ePhotos]
Revenir en haut Aller en bas
http://www.panoramio.com/user/616684
Peacemaker
Enkysté
Enkysté


Nombre de messages : 1392
Age : 49
Planète : Mars
Matos : MacBookPro 15' (2011), iPad4, Wacom Pen&Touch
Date d'inscription : 28/11/2006

MessageSujet: Re: (résolu!) Problème connexion   9/29/2007, 10:06

C'était bien le cas a)
Seul l'eMac avait perdu sa connexion.

Tes explications me permettent de mieux cerner le pourquoi de cette panne subite. Tu as un vrai talent de vulgarisateur... Content

_______________
...
Jusqu' où les chauves se lavent-ils le visage ?
Revenir en haut Aller en bas
http://oriot.net
TG
Légende vivante
Légende vivante


Nombre de messages : 5470
Age : 53
Planète : Paradis n°2
Matos : MacBook Pro Unibody 2.54 late 2008 Mountain Lion • MacPlus • PIXMA iP4300 • Scanner Epson Photo 330
Date d'inscription : 12/11/2006

MessageSujet: Re: (résolu!) Problème connexion   9/29/2007, 12:59

Il fallait bien que tu aies un problème pour que j'aie une explication ! (c'est pas une maxime Shadok mais ça pourrait !)

_______________
[MacJams] [RouteBuddy] [Winckler] [Panoramio] [ePhotos]
Revenir en haut Aller en bas
http://www.panoramio.com/user/616684
Contenu sponsorisé




MessageSujet: Re: (résolu!) Problème connexion   Aujourd'hui à 02:15

Revenir en haut Aller en bas
 
(résolu!) Problème connexion
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
MacNOMODO :: A i d e  &  d é p a n n a g e :: Aspects logiciels-
Sauter vers: